مشکل در نصب گراب

سلام
من مشکل نصب گراب دارم.
UEFI و secure boot هم خاموشه.
لینوکس رو لایو میارم از ترمینال این دستورات رو اجرا میکنم.
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
این اررو رو میده.
E: Unable to locate package
لطفا کمکم کنید نمیدونم باید چیکار کنم

این خطایی که شما می گیری ربطی به گراب نداره. برای نصب گراب این پیج رو ببینید:

https://help.ubuntu.com/community/Grub2/Installing

من قبلا با این دستورالعمل جلو رفتم اما ارور میداد