مشکل نصب پکیج pyplot در مک ( عدم پیدا کردن ورژن مناسب)

با درود خدمت دوستان گرامی. در موقع نصب پکیچ های pyplot در مک دچار مشکل شدن و خطا های زیر را در ایدتور دریافت کردم که یکی از این خطا ها اشاراه به عدم توانایی انتخاب ورژن مناسب می باشد. در صورت امکان راهنمایی بفرمایید برای حل این مشکل

3

سلام شما pythonenv تعریف کردید؟ وقتی با pip
شما pyplot رو میخواهی نصب کنی چه خطایی می بینی؟ توی ترمینال امتحان کنید

1 Likes

سلام
با PyCharm کار میکنم نه با خود python
در تصویر اول خطا مشخص شده
در تصویر دوم و سوم ورژن pip و pyplot مشخص شده
البته من این مشکل رو قبل ۲۰۲۱ نداشتم ولی ورژن جدید ماژول ها و PyCharm که اومد. همچی ریخت بهم
ممنون

توی ترمینال امتحان کنید بعضی ها با نسخه ۳.۹
مشکل دارند و میتونید به نسخه ۳.۸ downgrade کنید

1 Likes

سلام، تا جایی که من میدونم باید matplotlib رو نصب کنید!

pip install matplotlib

و توی کد:

import matplotlib.pyplot as plt
2 Likes

سلام
صفحه مربوط بهش توی پایپی این نیست؟

به گفته دوستمون SMMosavi شما اشتباه نصب میکنید.
به لینکی که فرستادم مراجعه کنید می‌بینید چطور باید نصب بشه توسط pip