پیش نیاز نصب postgresql در اوبونتو

دوستان برا نصب postgresql به مشکل خوردم خودش نصب میشه ولی برنامه هایی مثلazuredatastdio یا pgadmin4 نمیتونن درست ارتباط برقرار کنن
و اینو بگم انگار نیازمند یه فایل از پایتونه
ممنون میشم راهنمایی کنین

اگر خطایی که می گیری رو نشون بدی بهتر می تونیم راهنماییت کنیم

ممکنه روی پورت دیفالت نصب نشده باشه و پورتش فرق کنه که باید دستی به پی جی ادمین معرفی کنی . اول ببین پرتش دیفالت هست یا فرق می کنه

توی azurestdio هم مشکل داره بالا نمیاره نسخه اوبونتو هم نسخه جدیددشه

فکر می کنم خیلی مشکل از این نرم افزاری هایی باشه که استفاده می کنی. با کلاینت رسمی خود postgres از تو ترمینال وصل شو بهش و تست کن

مگه PgAdmin 3 هنوز اصلا نصب میشه؟

خطلایی که از اژور میگیری چیه؟

توی ترمینا مشکلی نداره اصلا هم جدول ها هستن و هم دیتابیس ها ولی توی این دو نرم افزار مشکل داره
در کل من بخوام به جدول هام دسترسی پیدا کنم بهترین راه چیه؟؟ و ساده ترین

سلام

اینجا هم مشکل اینه از پلاگین postgresql ایراد میگیره

من خیلی ازش استفاده میکنم تا حالا مشکلی نداشتم، دقیقا چه پلاگینی‌ نصب کردی؟
و چرا توی تنظیمات localhost به عنوان سرور انتخاب نکردی؟

انتخاب کردم وصل نمیشه باز
از خود نرم افزار پلاگین رو نصب کردم postgresql

به نظر من اول کلاینت خود postgres رو استفاده کن تا مطمئن شی مشکل از خود postgres نیست

1 پسندیده

مطمعنم مشکلی نداره postgres

اینو امتحان کن

sudo apt update
sudo apt install libssl1.0.0 libssl-dev

یعنی همه چی اوکیه فقط این لعنتی درس نمیشه

این چطور

sudo apt install libssl1.1