مشکل اپگرید pip (لطفا راهنماییم کنید)

سلام دوستان
من می خواستم pip را ارتقا بدهم اما با اخطارهای زیر مواجه شدم لطفا راهنماییم کنید.
WARNING: You are using pip version 19.2.3, however version 20.0.2 is available.
You should consider upgrading via the ‘python -m pip install --upgrade pip’ command.
بعد دستور python -m pip install --upgrade pip
میگه
-m’ is not recognized as an internal or external command,
operable program or batch file.
لطفا راهنماییم کنید…

حدث میزنم وقتی python --version میزنید، نسخه‌ی پایتون شما رو 2.7 نمایش میده. یعنی توی سیستم شما python لینک شده به python2.7
اسم نرم‌افزارها و کامندهایی که توی ترمینال وارد میکنیم در بعضی مواقع لینک شدن به اسم نرم‌افزار اصلی برای اینکه ما کامند کوتاه‌تری تایپ کنیم. برای دیدن این لینکها میتونید این کامند رو بزنید:

─$ ls -lha /usr/bin/python*
lrwxrwxrwx 1 root root    7 Nov 18 10:06 /usr/bin/python -> python2
lrwxrwxrwx 1 root root    9 Nov 18 10:06 /usr/bin/python2 -> python2.7
-rwxr-xr-x 1 root root 3.5M Jan 19 23:24 /usr/bin/python2.7
lrwxrwxrwx 1 root root    9 Nov 14 17:43 /usr/bin/python3 -> python3.7
-rwxr-xr-x 2 root root 4.9M Jan 20 02:04 /usr/bin/python3.7
lrwxrwxrwx 1 root root   33 Jan 20 02:04 /usr/bin/python3.7-config -> x86_64-linux-gnu-python3.7-config
-rwxr-xr-x 2 root root 4.9M Jan 20 02:04 /usr/bin/python3.7m
lrwxrwxrwx 1 root root   34 Jan 20 02:04 /usr/bin/python3.7m-config -> x86_64-linux-gnu-python3.7m-config
-rwxr-xr-x 1 root root 5.3M Feb 25 16:34 /usr/bin/python3.8
lrwxrwxrwx 1 root root   16 Nov 14 17:43 /usr/bin/python3-config -> python3.7-config
-rwxr-xr-x 1 root root  384 Feb  2 06:40 /usr/bin/python3-futurize
lrwxrwxrwx 1 root root   10 Nov 14 17:43 /usr/bin/python3m -> python3.7m
lrwxrwxrwx 1 root root   17 Nov 14 17:43 /usr/bin/python3m-config -> python3.7m-config
-rwxr-xr-x 1 root root  388 Feb  2 06:40 /usr/bin/python3-pasteurize

خطهایی که با l شروع شدن، به معنای لینک هستن. خطهای که با - شروع بشن فایل معمولی، خطهایی که با d شروع بشن دایرکتوری.

خب. بریم سر اصل مطلب.
توی سیستم شما احتمالا python2 دیفالته ولی pip که از این قضیه خبر نداره! کامندی که به شما داده مربوط به python3 میشه. اگه این دیفالت باشه، کامند درست اجرا میشه اگه نباشه باید دقیقا مشخص کنید که python3 باید اجرا بشه.
این کامند باید کار کنه:

python -m pip install --upgrade pip

البته از خود pip هم میتونید استفاده کنید. یعنی مستقیما خودشو صدا بزنید:

pip3 install --upgrade pip

و البته احتمالا لازمه که این کامند رو با sudo اجرا کنید. چون چیزی که قراره آپگرید بشه مربوط به کل سیستم هست و ربطی به virtualenv نداره و برای ویرایش این فایلها باید دسترسی root داشته باشید.

به امید روزی که از شر python2 خلاص بشیم.