مشکل nouveau در لینوکس (مینت)

سلام دوستان .
من یه مشکل عجیب تو لینوکس دارم که به این شکله .
وقتی لید لپتاپ رو میبندم یا به زبان عامیانه درشو میبندم و بعد چند دقیقه بازش میکنم همینجور یه صفحه سیاه با یه سری دستور از بالا به پایین میاد و بعدش در اخر مینویسه kernel panic

و بعدش یه سرچ زدم دیدم که یه چند جا نوشتن باید تنظیم کنی به جای اینکه وقتی لید بسته میشه به جای اینکه suspand بشه بزنید که lock screen بشه … و وقتی این کارو انجام دادم با کمال تعجب دیدم درست شد :grin::thinking:
حالا این مشکل به حساب میاد نمیدونم ولی خواستم بدونم چه جوری میشه درستش کرد .
ممنون از همتون :tulip:

باید متن اون کرنل پنیک رو هم بدی ببینم دلیلش چیه

1 پسندیده

اقا سمیر اینبارم این ارور رو داد . کرنل پنیک نکرد .

اول همینطور پشت سر هم ارور میداد بعد متوقف شد و نشد کاری کنم … ریستارت کردم

nouveau رو بکل لیست کن و از درایور خود nvidia استفاده کن

2 پسندیده

Nouveau پیشفرضه, میتونید در قسمت softwate & update و در تب additional drivers درایور مورد نیاز گرافیک رو نصب کنید.

اقا توماج واقعیتش اینه باز موفق نشدم …به این ترتیب انجام دادم ولی باز همون ارور بالایی رو داد.
اول Nouveau رو اینطور تو بلک لیست قرار دادم

sudo nano /etc/modprobe.d/disable-nouveau.conf

تو مسیر بالایی این کد هارو قرار دادم و ذخیره کردم

blacklist nouveau
options nouveau modeset=0

و بعد این دستور رو وارد کردم

sudo update-initramfs -u

و بعد رستارت که کردم از تو قسمت درایور منیجر از Nouveau به nvidia سوییچ کردم

و بعد با دستور:

lspci -k | grep -A 2 -i "VGA"

این خروجی رو بدست اوردم

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
Subsystem: Micro-Star International Co., Ltd. [MSI] Skylake GT2 [HD Graphics 520]
Kernel driver in use: i915

در ضمن لپ تاپ بنده دو تا کارت گرافیک داره …یکیش nvedia و یکیش intel

اینا هم اطلاعاتی که شاید کمک کنه

خروجی دستور

sudo ubuntu-drivers devices


== /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0 ==
modalias : pci:v000010DEd0000134Dsv00001462sd000011A4bc03sc02i00
vendor   : NVIDIA Corporation
model    : GM108M [GeForce 940MX]
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

اینم خروجی دستور

`sudo nano /etc/default/grub`




GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
1 پسندیده

باید از bumblebee استفاده کنی اگر هر دو کارت رو می خوای استفاده کنی

1 پسندیده

اقا سمیر نه همین اینتل که ضعیفه واسم کافیه …
مشکلم زیاد با suspend کردن بود که که هنوز پاربرجاست و وقتی suspend میکنم همون ارور بالایی که عکس دادم میاد . و برطرف نشده …
بنظرتون همون جور بمونه؟ مشکلی نداره که … چون فوقش suspend نمیکنم

اگر nvidia نیاز نداری کلا از تو BIOS خاموشش کن هم شارژ باطری بیشتر می مونه هم اینکه مشکلت حل می شه

2 پسندیده