مشکل نصب Gem در Rubymine

درود به همه عزیزان
من به تازگی به جمع شما بزرگوارا اضافه شدم و توی این زمینه تازه کار هستم
روی ویندوز Rubymine رو نصب کردم ولی برای ایجاد پروژه rails مشکل نصب Gem دارم و ظاهرا به خاطر مشکل فیلتر ایران هستش خطای آدرس یا پروکسی رو دارم
کسی به چنین مشکلی برخورده قبلا چون با انواع VPN هم مشکل من حل نمیشه
ممنونم

خطایی که دریافت می کنید رو اگر اینجا کپی کنید بهتر میشه راهنمایی کرد.

خطاهای مربوط به نصب روبی یا نصب gem که بیشتر بخاطر ssl یا cdn هست بطور معمول با استفاده از پ.ر.ا.ک.س.ی حل میشه.

1 پسندیده

ممنون

فکر می کنم مربوط به همون ssl باشه چون توی کامند هم اررور ssl گرفتم
ولی به صورت دستی تونستم یه sdk بهش بدم و ورژن Rails رو مشخص کنم ولی خوب خودش متاسفانه نمیگیره همچنان

سلام،
بعضى از دوستان توى همين سايت اين مشكل رو داشتند و با استفاده از proxy یا vpn مشكل حل شد,برای بعضی ها هم حل نشد . اما احتمالا در ويندوز مشكلات زياد دیگری هم براى كار با ريلز خواهيد داشت و به هيچ عنوان ويندوز را براى ريلز پيشنهاد نميكنم. البته نه اینکه شدنی نیست, اصلا منطقی به نظر نمیاد :frowning:
مك يا لينوكس گزينه هاى بهترى هستند،
اگر خواستيد از لينوكس روى دسكتاپ يا لپتاپ استفاده كنيد، Linux Mint يا Ubuntu كه هر دو از يك خانواده هستند خيلى مناسب به نظر ميان.
اگر Virtualization کار شما راه میندازه میتونید از Vagrant توی ویندوز استفاده کنید.

شاید لینک زیر به کار بیاد:

1 پسندیده

:smiley: بیشتر کرمش گرفته چون هم مک وجود داره و هم ubunto دارم برای کار باهاشون

خب اگر خيلى مشتاق هستيد تلاش خودتونو بكنيد و اگر نتيجه داد ما رو هم با خبر كنيد :slightly_smiling_face:

از کامند آپدیت کردم ریلز رو به 5 و بعدش همون ssl رو و الان مشکلم خطایی هستش که ظاهرا مربوط به Devkit هستش
آروم آروم میرم به سمت همون Mac :smiley:

1 پسندیده

سريعتر لطفا، تو ويندوز فقط وقت طلف ميشه :joy:

1 پسندیده

:smiley: موافقم

1 پسندیده

حتما خودتون بهتر ميدونيد كه توى لينوكس و BSD ها از جمله مك باRbenv كارا خيلى ساده تر ميشه، اگر من جاى شما باشم بدون rbenv كار نميكنم، من از لينك زير براى استفاده از rbenv كمك ميگيرم.

1 پسندیده

سپاس فراوان
بله
تمام موارد قبلا نصب شده روی مک

:pray: