مشکل نصب gem install json -v '1.8.3'

سلام
دوستان gem install json -v ‘1.8.3’ نصب میکنم ارور زیر را میده علت از چیه ؟
سیستم عامل debian 8 64 bit

Building native extensions. This could take a while…
ERROR: Error installing json:
ERROR: Failed to build gem native extension.

/usr/bin/ruby2.1 extconf.rb

creating Makefile

make “DESTDIR=” clean
sh: 1: make: not found

make "DESTDIR="
sh: 1: make: not found

make failed, exit code 127

Gem files will remain installed in /var/lib/gems/2.1.0/gems/json-1.8.3 for inspection.
Results logged to /var/lib/gems/2.1.0/extensions/x86_64-linux/2.1.0/json-1.8.3/gem_make.out

سیستم عاملت چیه ؟

اگر از Debian استفاده میکنی (.Debian, Ubuntu, Linux Mint etc) فرمان زیر اجرا کن که build-essential نصب بشه, بعد دباره سعی کن جم نصب کنی شاید درست بشه.

sudo apt-get install build-essential

بله مشکل حل شد اما یک مشکل دیگه به وجود اومد
ببینید من دارم از انجمن ساز Discourse استفاده میکنم حالا میخوام از انجمن قبلیم که easydiscuss بود مهاجرت کنم به جدید . برای این کار یک اسکریپت بود که میخواستم اجراش کنم نیاز به نصب bundle بود زمان نصب این bundle به این مشکلات بر خوردم
حال که json نصب شد از
An error occurred while installing pg (0.18.4), and Bundler cannot continue.
Make sure that gem install pg -v '0.18.4' succeeds before bundling.
داره ارور میگیره
به نظرتون من چه کار کنم میام gem install pg -v ‘0.18.4’ نصب میکنم ارور زیر بهم نشون میده
extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.1.0/gems/pg-0.18.4 for inspection.
Results logged to /var/lib/gems/2.1.0/extensions/x86_64-linux/2.1.0/pg-0.18.4/gem_make.out

Debian 8.3 64 bit

سعی کن کل اررو رو تو gist بزاری که بهتر برسی بشه. اما خط زیر رو هم اجرا کن که pg نصب بشه اگه نشد کل اروور رو بده

sudo apt-get install libpq-dev

ممنون از لطفت
درست شد تشکر

1 پسندیده