Error نصب bcrypt

می‌خوام یه gem رو به پروژه‌م اضافه کنم. موقع استفاده از ذعدیمثق با این error مواجه می‌شم:

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

/usr/bin/ruby2.1 extconf.rb

mkmf.rb can’t find header files for ruby at /usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in /tmp/bundler20151208-2837-1lnbeigbcrypt-3.1.10/gems/bcrypt-3.1.10 for inspection.
Results logged to /tmp/bundler20151208-2837-1lnbeigbcrypt-3.1.10/extensions/x86_64-linux/2.1.0/bcrypt-3.1.10/gem_make.out
An error occurred while installing bcrypt (3.1.10), and Bundler cannot continue.
Make sure that gem install bcrypt -v '3.1.10' succeeds before bundling.

bcrypt 3.1.10 رو قبلش با gem نصب کردم ولی باز با این ارور مواجه می‌شم.

داری از روبی سیستمت استفاده می کنی . ruby-dev رو نصب کن و یا از اون بهتر اینکه از rbenv استفاده کن

1 پسندیده